× This forum is read only. As of July 23, 2019, the UserSpice forums have been closed. To receive support, please join our Discord by clicking here. Thank you!

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Stuck on Step 3 of Install
#1
Hello,
I'm a PHP newbie, but have XAMPP installed and successfully running with SQL.

THANK YOU for the install video! So many tech guides seem to omit little details presumably assuming that the little things are basic knowledge, but even tiny details often hang me up.

I'm on Step 3 of the install process, following along with the install video. But for some reason I get the error message "Database connection unsuccessful! Please try again", even though I followed steps 1 and 2 exactly.

I actually followed the install video (https://www.youtube.com/watch?v=ayQR95-V5hA) to the letter, right up to 1:55 where I can't continue because of the error.

So...is there some little detail that everyone takes for granted that a newbie like myself has inadvertently skipped? Some config setting? Some obscure incantation? Please note I followed the video above exactly.

Thanks very much for your time, D
  Reply
#2
Did you create the database? If you didn't create one, go to http://localhost/phpmyadmin and look at this pic...
http://puu.sh/uhZz1/d8b8a13cb2.png

Click new in the upper left hand corner. Type your name in the Database Name Field. Hit Create. If you're on xampp, your settings are almost definitely...


localhost for hostname (if that doesn't work, put 127.0.0.1)
root for username
leave password blank
database name is whatever you called your database that you created.

Let me know if you're still having problems. We'll get you through this.

  Reply
#3
Good morning Mudmin, thanks very much for your time. I actually did create the database, duplicating what is done in the demo video (I literally followed the process described at :40 in the video https://youtu.be/ayQR95-V5hA?t=41 )

Is there any other server side assumption that isn't outlined in the video? My settings are all good as described at 1:36 in the video so not sure what I'm missing!

Here are screen caps of my screens leading up to/including the fail screen

https://www.dropbox.com/s/tk16riwqoyaxpl...6.png?dl=0

https://www.dropbox.com/s/6ooi28ujnoynqx...6.png?dl=0

https://www.dropbox.com/s/w29xb3ydxlid3k...8.png?dl=0

https://www.dropbox.com/s/zg9jqekpg7amwk...1.png?dl=0

Thanks again, D
  Reply
#4
im not at all familiar with xampp. But it may have bound to the computers actual local ip address it should how ever still respond to localhost or 127.0.0.1. But we all know how computers are sometimes. Chances are its just a database error not being set up at all, or configured wrong.

mudmin way should work but we each have our own way

so ill make you a small walk through on how i do it Smile with phpmyadmin
now i run apache2 with mysql on ubuntu 14.04 i have multiple instances of Ubuntu and Debian 8 using this single mysql server. the mysql is installed on the web server i run the same program Multicraft (its for minecraft) on mutiple physical servers but the banning suite and mutlicraft databases are located on the main web server that that runs the main proxy for the minecraft called bungeecord. i have combined power usage of my system is approx 1500 watts at full load it idles down in the high 500's so it does cost me quite a lot to run them approx 140 dollars a month.

i esplained that simply so this next part made sense when i make my database using anyhost {3bc1fe685386cc4c3ab89a3f76566d8931e181ad17f08aed9ad73b30bf28114d} vs localhost its becase its the only mysql server i use.

step 1
login to phpmyadmin using localhost/phpmyadmin
now locate the users tab on the top upper left third of the screen
http://prntscr.com/ed7gkz

step 2
click on add user bottom left third of the screen
http://prntscr.com/ed7gr8

step 3
fill in the username i used test use what ever you want
make sure the host line says anyhost on the drop down to the left of the editable field
i allow phpmyadmin to generate a password for me
check the box thats half way down on the left thrid that says create database with the same name and grant all privileges
ignore everything else on the page scroll to the bottom after you have copyied your password (or made your own) click on go bottom right side of the screen.
http://prntscr.com/ed7hnb

step 4
fill in the info on the install step i am showing you a copy of my init.php because i no longer have the install files
fill in the host info mine shows the local ipaddress of the server
user name
password
and database name this will be the same as the user name because we checked the box that said create database with the same name and grant all privileges
http://prntscr.com/ed7ln9

this method will ONLY work if your machine has a static ipaddress i cannot stress that enough if it doesn't have a static ip it will work for a while then it will break in a few days typically.

to find your local ip address open up a terminal (cmd prompt in windows)
on windowes open command prompt and type in ipconfig
http://prntscr.com/ed7msq

on mac/linux use ifconig -a
http://prntscr.com/ed7nn5

to assign a static ip address on windows follow this guide
https://www.howtogeek.com/howto/19249/ho...windows-7/

for mac use this guide
http://www.macinstruct.com/node/550

on linux its actually simpler imo
step 1 ifconfig -a make note of your settings mostly just the ipaddress and the interfaces name eg mines em3 it could be eth0 or a number of things
http://prntscr.com/ed7nn5

step 2
for the sake of this im going to use the nano editor but use the one you want there is a few of them

type this command in sudo nano /etc/network/interfaces

if your logged in linux as root you don't need sudo
it will open this screen
http://prntscr.com/ed7r1r

if it already is static it will look like mine others wise the line on mine that says iface em3 inet static will say iface em3 inet dhcp

change that line to
iface em3 intet static
address (your local ip address) xxx.xxx.xxx.xxx
netmask 255.255.255.0 (or what ever your netmask it probally 255.255.255.0 its the most common
gateway (what ever your routers local ip address is. or your dhcp servers ipaddress)
dns-nameservers 8.8.8.8 (this is googles free dns server)

then hit ctrl x then hit y then hit enter

mow restart the networking service or just restart the computer what ever is easier for you


i did this as a wide help simply because for some reason i can see this happening often enough Smile

R
  Reply
#5
DarrenH.

i hope this helps you out passwords are typically a very good idea
if this doesnt help let me (us) know
  Reply
#6
Yeah. Xampp isn't designed to host live websites, so they don't have a password on mysql by default. It's only for development.
  Reply
#7
Thanks so much Raven. So the basic takeaway is: "you need a static IP address for this install to work" I'm guessing : )

If I'm having this issue it must be the case for most people...my setup is vanilla typical (broadband ISP, etc.)

Will see what I have to do and report back...many others are probably having the same challenges...

Thanks, D
  Reply
#8
You should not need a static ip. I don't use one on any of my systems.

Here's the deal... in pretty much all cases 127.0.0.1 means localhost.

being able to go to localhost/mypage MIGHT not work if there's something going on with your dns as localhost actually makes a dns query to send itself back to your computer.

So, let me ask you:
how are you accessing the userspice setup?
is it
localhost/userspice
or 127.0.0.1/userspice (or whatever your page is)

Secondly. If you navigate away from the install page and go to phpmyadmin (via localhost or 127.) does it load? If not, is your mysql running? (if you go to your tool tray and right click the xampp logo, is mysql green?)

Thirdly? is there a chance that you have multiple server programs running (Like both WAMP and XAMPP)?
  Reply
#9
what antivirus are you running i wonder if its not some how interfering i dont run antivirus on my LAMP stacks (Linux Apache Mysql Php) I have a nat firewall on the dhcp server thats it

and mudmin your right for local testing you shouldnt need a static i have to run statics because i have mutiple servers using the same databases for cross server operations.

DarrenH
http://prntscr.com/edd0c6

humor me and try these settiing for the database im trying to narrow what exactly is wrong because i run mysql as anyhost i can port databases to the main web easily.

use hostname www.ravencraftnetworks.com
database user netremote
password PydDwXcQ29QtAMZU
database name netremote

if its sucessful then i blame something with your sql in xampp if its still doesnt work then im not sure what to blame


IMO it may just be simpler to run a VM virtual machine program and actually run an offical lamp stack its a lot more tech intense but oh so nice imo. and there is usually no excuse something doesnt work unless something is missing lol. i can always create a guide to setting up oracles virtual box system and include a download for the VHD file of one of my unused vm i made fully configured and ready to go has a static and everything all you would have to do is a bit of config work on your end setting the bridged network settings and ram and pointing it at the vhd file. hell ill even preinstall userspice there is no reason its giving you this much trouble this is silly.

R

https://www.virtualbox.org/wiki/VirtualBox

www.ravencraftnetworks.com is my userspice up and running with a few clocks im messing with ones js if i remember right
  Reply
#10
Hi Mudmin, here's what happens in these scenarios, if that helps? I was able to do everything in the tutorial video right up to the point of failure so it *seems* as if everything is working properly. But we'll see.

127.0.0.1 results in bouncing to 127.0.0.1/dashboard and I get the XAMPP 'welcome' screen ("You have successfully installed XAMPP on this system! Now you can start using Apache, MariaDB, PHP and other components")

**Since I literally followed the tutorial video mentioned above**, 127.0.0.1/demo/ jumps to the "Welcome to InstallSpice 0.1a" screen at 127.0.0.1/demo/install/index.php

The same thing happens if I use 'localhost' instead.

localhost/phpmyadmin/ navigates to the phpMyAdmin page, where I can see my 'demo' database set up **as per the demo video above**

The same thing happens if I use 'localhost' instead.

MySQL is running, here's a screenshot of the running window:
https://www.dropbox.com/s/0nk4vpn6ludsec...9.png?dl=0

Question: Are these the right default settings for setting up a new database for UserSpice? **in the demo the speaker simply enters 'demo' as the name, clicks 'create' and it's done**

https://www.dropbox.com/s/bc3ggg8m1fq95y...2.png?dl=0

THANKS! D
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)